I need a bit of help with metacreator

So I'm getting ready for my first Ars Magica game. Still learning the rules and such. Bought metacreator because it looked like it would be a huge help with bookeeping. I've been using HeroLab for years with Mutants and Masterminds, Pathfinder, and Savage Worlds.

So I made a covenant, and named it 'First Saga' in which I included a few teachers.

Then I loaded my character and added the 'First Saga' covenant to his sheet.

So now I want to figure out how to do advancement inside metacreator. I click on Magic Theory, then teaching in the shortcuts and select Theon as my teacher and I get this error.

Am I doing something wrong? Does metacreator not work worth a darn?

Probably better to address this to the makers of MetaCreator.

I may have run into this error, or a similar one before, I can't recall the specifics. Are the covenant and the character in the same folder?

yes in same folder. I looked for metacreator forums, they had a message system that was just a mess. Thought i'd try my luck here. it works fine if I just input Theon's stats manually in the teaching window but trying to import them seems broken.

It's not the most active forum in the world, but the support is pretty quick. They were extremely responsive when I asked them to fix Flawless Magic.
It might be better to stub out the character and go that way. I'm currently struggling with some upgrade related issues, it tells me my characters are of a different version, and doesn't update them properly, or I'd simulate the problem more completely.

Are you advancing Pavarius in his character sheet or in the Covenant character sheet.

What I do (using example apprentice Geoffrey and teacher Boudicca) is:

  • Open Geoffrey's character sheet.
  • Click on the art/ability that I want him to be taught in.
  • In the left-hand bar, under "Advance", click on "Teaching". That opens up a window called "Teaching."
  • At the bottom of that window, click the button labeled "Teacher".
  • Click and open the teacher character (it pulls up the same window that you get when you go to open a character sheet).
  • Click "OK" and your character gets the appropriate number of experience points from the teacher's SQ.

I also tried using a Specialist that's in my covenant sheet that has the ability, going the same route you showed in your screenshot, and it didn't work, even though it should have. Sounds like it could be a bug. I would go to the yahoo group (groups.yahoo.com/neo/groups/cw/info), start a new thread by clicking the purple "New Topic" button on the Conversations page, and ask. That's what I do when something weird comes up.

I had that issue recently where I had a character created using an older version, and my custom definition files were out of date as well.

For the first problem try Utilities > Update Character Sheets. The second means updating the version definition in the sheet. Both have help content to show how to solve them.

I forgot to mention that if you click on "ok" with this, it still adds the appropriate number of experience points.

I also didn't realize that I was using an ever-so-slightly outdated version, so all my advice may be hogwash. I'll try it tomorrow and see.

Metacreator is excellent, but does have a couple of tricky aspects. I've never tried to use a teacher from a covenant, I've simply put in the teaching quality or the correct xp value manually.

One thing that is truly excellent is the response you get from the people who make it. Send them an email directly, you're likely to get an answer and/or a fix within a couple of days.